Linux version
  • I'm running 64-bit Kubuntu Linux 13.04, running on a stock Nouveau video driver. I can confirm that the Linux version of Energy Hook does not run, at least for me. I've chmoded the executable to +x and tried it as root and as my regular user. In the terminal, I simply get "EnergyHookLinux: EnergyHookLinux: cannot execute binary file"

    I'd be delighted to help test this, as I only run Linux machines these days and would love to be able to play the game. Has any other Linux user been able to successfully run the executable?
  • I can run it, on 64-bit Gentoo. It's a 32-bit executable; maybe you're missing some 32-bit compatibility package?
  • Thanks, djw; after installing the ia32 multiarch libs in Ubuntu, I can run the game.
  • That's awesome to hear people are able to run it on Linux!
    Sorry for making you do my testing for me.
    There's a x86 + x86_64 "universal" build option in Unity - I'll try that one next time, hopefully 64-bit people won't have to install anything extra.
  • No worries; I love that I can play a game and provide feedback and the developer is right there -^ in the conversation. I can definitely run it on my two 64-bit machines (both Kubuntu 13.04) after installing the ia32 multiarch library package (and all the dependencies therein), but it's a big install; 270 MB of stuff.

    My first run on the game was on my home machine, a three-year-old Toshiba with 3 GBs of RAM, an Intel Core 2 Duo chip, an NVidia GForce G210M video card with 512 MB of RAM, and a regular 7200 RPM IDE hard drive. I could see the HUD and read the tutorial messages, but there were lines and ghosting through the jet pack/boost meters and the rest of the HUD. As I mentioned, I'm not using the NVidia video driver; I'm using the stock Nouveau driver, so it's possible the lines/ghosting might clear up if I try that. The NVidia driver has given me problems in the past, though, so I need to make sure my backups are adequate before I try to install them. I'll report back soon, depending on how my extended 4th of July weekend goes.

    I also tried the game on my work machine, a two-year-old Dell with 16 GB of RAM, a second gen Intel Core i7 chip, an AMD Radeon HD 6700M video card with 1 GB of GDDR5 RAM, and a 128 GB SSD. Errors in running the executable again led me to install the ia32 multiarch package, after which I could successfully run the game. Shocking no-one, the game is much smoother on the beefier machine, though to my surprise, I've got the HUD bug (aka no HUD at all; I*am* running the AMD Catalyst driver on this machine). The game started up fullscreen on my second screen (the 21" display) with no other problems, and even with no HUD, the game is incredibly fun. I spent enough time on the tutorial on my home machine to be able to move around, but it's not like it's hard to figure out.
  • A quick note: on my Dell laptop (the AMD machine), I get the HUD back if I run the game in windowed mode (I tried it at 1024x768). I need to get back to packing for my trip, though, so I won't be able to do any testing on the "good" laptop until Sunday.
  • Ghosting and distortion goes away on the NVidia machine when I run windowed in 800x600 resolution. Game runs way more smoothly as well. It's likely that machine is near the bottom end of the minimum specs needed to run the game.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook