New Alpha Release v138 7/5/13 - new UI
  • What's new in this build?

    * NGUI gui works
    * UI works with Oculus
    * Invert camera controls
    * Control jetpack type from pause menu
    * Harder to 'cheat' in challenge levels
    * Linux "universal" build

    What doesn't work?
    * The mouse in the Pause Menu - but you can use the arrow keys on the keyboard and Enter to navigate and select options

    How can you help?
    * Check out the challenge levels and tell us what you think. Want more or less of them?
    * Playing with an Xbox 360 gamepad on a Mac? Are the buttons mapped correctly?

    Enjoy! Post your feedback here!

    BTW - are you one of the hardcore few who don't want to miss a single update? And you know that Facebook, Twitter, and RSS feeds are unreliable? (Well, RSS feeds aren't *that* unreliable, unless you're like me and have subscribed to a hundred things and forget to read it for weeks a time...) And you don't want to have to remember to check the forum? Well, if that's you, I've just opened yet another frickin' line of communication: a mailing list just for Energy Hook updates:
    http://eepurl.com/BY819
  • awesome cant wait to play it :D

    i'm not sure what html and text meant in that mailing list sheet, so I clicked html.

    I think some of the challenge levels might be a little weird with those tiny dots you have to hook onto... I made a video of it http://youtu.be/YD_CcJ8K7BQ I play the levels near the end. Its near impossible when it seems like I'm doing the same thing again and again but sometimes it works and sometimes it doesn't. I guess the challenge levels could be awesome but right now they are showing off some things about the hook that probably needs fixing. I'm not sure I'm a musician not a game developer so keep that in mind.
  • Using build 138, whenever I try to click on any of the options after hitting esc, such as inverting the y axis, the DONE button does it's little animation, then the screen seems to 'freeze', hitting esc takes you back to the game, but the controls don't change.
    I've also noticed that once in a while when I fire up the game, the camera will be far too close with no way to zoom out.
  • I have used the keyboard to toggle x and y axis inversion, but it doesn't actually invert the controls.
  • Same problem here: all inverting options are ticked by default, and ticking them any which way doesn't change a thing.

    Also, the resolution is still not saved in the launcher.
  • Thanks guys - the pause menu should be fixed in the latest update - the mouse still doesn't work but the options do.
  • Hi Jaime,

    For the Rift, the tutorial text is essentially unreadable. For it really to work, it needs to be inn the center and larger. Check out Blue Marble or Lunar flight for great examples of text that works in the Rift!
  • Thanks Huckleberry! I was hoping the consumer Rift with the higher res will fix that, but I'll check out those games.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook